To be able to use Youth Internet Masters you should have Flash Player 11 or higher installed. This program has been tested in Internet Explorer, Firefox, Safari, and Opera. The program may not work in Google Chrome.

Para usar el Programa Jóvenes Maestros de Internet debe tener instalado Flash Player 11 o más reciente. Este programa ha sido probado en Internet Explorer, Firefox, Safari, and Opera. El programa puede no funcionar en Google Chrome.